مثال – Queue , Mangle

سلام به همه دوستان تن تنی.همانطور که در بخش قبلی گفته بودم در این بخش قصد دارم مثالی ساده برای استفاده از Mangle و Queue را اجرا کنم.

خب فرض کنید ما قصد داریم یکسری از پکت ها را ابتدا Mark  کنیم سپس روی آنها محدودیت اعمال کنیم برای اینکار ابتدا از قسمت فایروال تب Mangle را انتخاب کرده و روی + کیلک می کنیم.

ex1

از قسمت Chain نوع پکت ها Forward انتخاب میکنیم.زمانی که شما Dst.address  و Src.address را وارد نکنید یعنی اینکه تمام پکتی های ارسالی به تمامی مقصد ها(بستگی به نوع تنظیمات دارد)،نوع پروتکل هم TCP می باشد.در تب Action دو نوع Mark وجود دارد که در Chain Forward می توان انتخاب کرد.

بیشتر بخوانید

Queue در میکروتیک

سلام به همه دوستان تن تنی. در این پست قصد دارم شما رو با یکی دیگر از امکانات میکروتیک یعنی Queue آشنا کنم.Queue برای محدود کردن و اولویت بندی ترافیک ها و پهنای باند استفاده می شود:

*محدود کردن Rate داده ها برای یک آدرس IP مشخص،Subnet،پروتکل ها،پورت ها و دیگر پارامترها…

*محدود کردن peer to peer ترافیک ها

*الویت بندی بعضی از packet های در حال جریان نسبت به دیگر بسته ها

*پیکربندی ترافیک ها برای ساده ترشدن مرورگرها

*اجرا کردن محدودیت های مختلف بر اساس زمان

*ُبه اشتراک گذاشتن ترافیک های موجود در میان کاربران به یک اندازه

اجرا Queue در میکروتیک روتر براساس HTB است (Hierarchical Token Bucket).HTB اجازه می دهد تا ساختار Queue ها بصورت سلسه مراتبی ایجاد شود و روابط بین آنها تعیین شود.در روتربردها این ساختار سلسله مراتبی به ۴ قسمت مختلف تقسیم می شود FIFO,RED,SFQ,PCQ

برای انجام پیکربندی از منو سمت چپ گزینه Queue را انتخاب میکنیم.

Queue

در پنجره باز شده مربوط به Queue List چهار تب Simple Queues,Interface Queues,Queue Tree,Queue Types مشاهده می کنید.

بیشتر بخوانید

فایروال میکروتیک – بخش سوم

فایروال میکروتیک – بخش سوم

سلام به همه دوستان تن تنی.در بخش های قبل در مورد دو تا از تب های Firewall یعنی Filter Rules ، NAT مطالبی را بیان کردم و برای یادگیری بهتر شما باید خودتون سناریوهایی مطرح کنید وسعی کنید آنها را پیاده سازی کنید تا با طور کامل با عملکرد میکروتیک و بخش های مختلف آن آشنا شود.در این بخش قصد دارم تب های دیگر فایروال یعنی :

Mangle,Service port,Connection,Address list,Layer 7 Protocol

بررسی کنیم و توضیحاتی ارائه بدم و در آخر برای فهم بیشتر به حل سناریو بپردازیم.

بیشتر بخوانید

فایروال میکروتیک – بخش دوم

فایروال میکروتیک – بخش دوم

سلام به همه دوستان تن تنی.در بخش قبل در مورد Filter Rules مطالبی را بیان کردم در این بخش قصد دارم شما را با تب دوم Firewall یعنی NAT آَشنا کنم . NAT یکی از ابزارهای قدرتمند دنیای IT است که به وسیله آن میتوانیم آدرسهای یک شبکه را به یک شبکه دیگر ترجمه کنیم.NATتقریبا در تمامی سیستم عاملها و روتر ها قابل انجام است که هر کدام شیوه و روش خود را دارند.قبل از اینکه بریم سراغ کانفیگ های مربوط به NAT.. اول از همه لازم از خودمون بپرسیم NAT چیست؟؟ چه کارایی داره؟؟ مزایا و معایب NAT چیست؟؟ و… که بصورت مختصر توضیح میدهم.

بیشتر بخوانید

فایروال میکروتیک – بخش اول

فایروال میکروتیک – بخش اول

سلام به همه دوستان تن تنی. در این پست قصد دارم شما رو با Firewall میکروتیک که یکی از بخش های مهم و پرکاربرد امنیتی سیستم عامل میکروتیک است،آشنا کنم.با استفاده از Firewall  میکروتیک شما می توانید از دسترسی های غیر مجاز،ورودی و خروجی را کنترل کنید.قبل از انجام هر گونه تنظیمات فایروال تمام packet  ها از همه اینترفیس ها می توانند عبور کنند.ما با ایجاد Rule  در فایروال که امکانات زیادی در اختیار ما قرار می دهد میتوانیم روی ورودی ها و خروجی ها کنترل داشته باشیم و یک سری تنظیمات امنیتی روی آنها اعمال کنیم.

بیشتر بخوانید

نحوه Upgrade کردن سیستم عامل میکروتیک

نحوه Upgrade کردن سیستم عامل میکروتیک

سلام به همه دوستان تن تنی.همراه هستم با شما در نحوه Upgrade کردن سیستم عامل (OS) روتربردهای میکروتیک به طوری که در پایان شما براحتی بتوانید بر اساس نیاز ورژن ،روتربرد خود را تغییر دهید.گاهی اوقات در ورژن فعلی که دارید از روتر استفاده میکنید احتمال داره bug  وجود داشته باشه و یا میخواهیم با Upgradeکردن یکسری ویژگی های جدید به روتر اضافه کنیم.قبل از انجام Upgrade حتما یک Backup از روتر خودتون تهیه کنید،تا اگر هنگام انجام پروسه Upgrade برق روتر قطع شد و روتر از نظر نرم افزاری با خطا مواجه شد و load نشد بتونید با برگرداندن backup تنظیمات روتر رو داشته باشید که در پست قبلی بطور کامل براتون نحوه backup گیری بصورت خودکار و دستی توضیح دادم.

موضوعات مورد بررسی :

     Automatic upgrade

     Manual upgrade methods

     Upgrade process

بیشتر بخوانید

نحوه Backup گیری اتوماتیک میکروتیک

نحوه Backup گیری اتوماتیک میکروتیک

سلام به همه دوستان تن تنی. در این پست قصد دارم شما رو با نحوه backup گیری اتوماتیک میکروتیک اشنا کنم.شاید خیلی وقت شما نیاز داشته باشید  در یک ساعت خاص از روز یا در یک بازه زمانی، از تنظیمات روتر میکروتیک خودتون backup بگیرین ولی به هر دلیلی در اون بازه زمانی  خودتون حضور ندارین،شما میتونید باانجام یکسری تنظیمات این کار به عهده خود روتر بزارین تا براتون عملیات Backup گیری انجام بده. مباحثی که قصد دارم در این پست باهم بررسی کنیم بصورت زیر است:

    ۱ E-mail backups

    ۲ Automated central backups

        ۲٫۱ Introduction

        ۲٫۲ Router configuration

        ۲٫۳ Server configuration

        ۲٫۴ Creating an FTP script template

        ۲٫۵ Configuring Windows scheduler

    ۳ Final adjustments

*E-mail backups*

یکی از ساده ترین روش ها backup گیری اتوماتیک  استفاده از سیستم ایمیل ساخته شده در میکروتیک است. تنظیم آن متشکل از چند دستور و با بهره گیری از زمانبندی برای اجرای اسکریپت ایمیل در هر زمان داده شده است. قبل از ادامه برای  اجرای اسکریپت ایمیل، لازم که مطمئن باشید سیستم پست الکترونیکی  برای ارسال ایمیل به درستی پیکربندی شده است.با تایپ دستور زیردر کنسول NT شما میتوانید این کار را انجام دهید

/tool e-mail print

شما باید ی خروجی شبیه خروجی زیر دریافت کنید

server: 192.168.0.1

from: mikrotikbackup@yourhost.com

که “۱۹۲٫۱۶۸٫۰٫۱”   آدرس SMTPسرور شما و mikrottikbackup@yourhost.com ایمیل آدرسی هست که MTبرای شناسایی خودش وقتی backup ها را ارسال میکند استفاده خواهد کرد.اگر شما همچنین خروجی مشاهده نکردین شما باید تنظیمات مربوط به کانفیگ e-mail را با استفاده از دستور زیر انجام بدهید:

/tool e-mail

set server=192.168.0.1 from=mikrotikbackup@yourhost.com

در این قسمت شما باید اسکریپت های لازم برای ارسال ایمیل وارد کنید.طبق دستور زیر:

/tool e-mail send to=”youremail@yourhost.com” subject=([/system identity get name].” backup”) file=email.backup;

:log info “Backup e-mail sent.”;

بجای youremail@yourhost.com شما باید ایمیل مربوط به دریافت کننده را وارد کنید.اگر شما تصمیم داشته باشید از چند ایمیل ادرس استفاده کنید ،دستورات زیر را اجرا کنید :

/system script

add name=”e-mail-backup” source={/system backup save name=email;

/tool e-mail send to=”youremail1@yourhost.com” subject=([/system identity get name].” backup”) file=email.backup;

/tool e-mail send to=”youremail2@yourhost.com” subject=([/system identity get name].” backup”) file=email.backup;

/tool e-mail send to=”youremail3@yourhost.com” subject=([/system identity get name].” Backup”) file=email.backup;

:log info “Backup e-mail sent.”;  }

آخرین مرحله، config زمانبندی برای اجرای اسکریپت بالا در یک بازه زمانی است .اجرای دستور زیر باعث میشود هر روز اسکریپت اجرا شود:

/system scheduler

add comment=”” disabled=no interval=1d name=”e-mail-backup” \

on-event=e-mail-backup start-date=jan/01/1970 start-time=00:00:00

وقتی انجام می شود، شما می توانید تنظیمات خود را  در Winboxبررسی کنید، وباید به چیزی شبیه شکل زیر برسید:

backup1

backup2

Router configuration

اول از همه، ما باید تمام روترهایی رو که نیاز به طور مکرر backup  بگیرن رو کانفیگ کنیم. (در این مثال، من میخوام هر روز این کار انجام بده) برای این کار، من باید این دستور در هر روتر  اجرا کنم:

/system scheduler

add name=”backup” on-event=”system backup save name=today.backup” \

start-date=jan/01/1970 start-time=00:00:00 interval=10h comment=”” \

 disabled=no

دستور بالا خیلی ساده است،یک فایل Backupمیکروتیک به نام “today.backup” که هر ۱۰ ساعت انجام خواهد شد را ایجاد میکند. ما میتونیم به فایل های Backup توسط سرور اصلی از طریق FTP دسترسی داشته باشیم . با اجرای دستور زیر ما مطمئن خواهیم شد که همه چیز به درستی کار میکند:

/system backup save name=today.backup

خب بعد از این مرحله فایل backup  باید ایجاد شده باشد. برای اطمینان به لیست فایل ها مراجع میکنم:

backup3

در قسمت روتر تنظیمات  تقریبا کامل است، اما باید مطمئن بشیم که دسترسی به FTP موجود است:

/ip service print

When the command is executed, the following output (or similar) should appear:

Flags: X – disabled, I – invalid

 #   NAME      PORT  ADDRESS       CERTIFICATE

 ۰   telnet    ۲۳    ۰٫۰٫۰٫۰/۰

 ۱   ftp       ۲۱    ۰٫۰٫۰٫۰/۰

 ۲   www       ۸۰    ۰٫۰٫۰٫۰/۰

 ۳   ssh       ۲۲    ۰٫۰٫۰٫۰/۰

 ۴ X www-ssl   ۴۴۳   ۰٫۰٫۰٫۰/۰     none

 ۵ X api       ۸۷۲۸  ۰٫۰٫۰٫۰/۰

 ۶   winbox    ۸۲۹۱  ۰٫۰٫۰٫۰/۰

اگر در خروجی اسکریپت بالا هیچ “X” در کنار آیتم FTP در لیست ظاهر شده وجود نداشته باشد یعنی اماده برای انجام ادامه برنامه است. توصیه میشود بدلایل امنیتی برای هر روتر بصورت مجزا یک FTP ایجاد کرده :

/user group

add name=”ftp” policy=ftp,!local,!telnet,!ssh,!reboot,!read,!write,!policy,!test,!winbox,!password,!web,!sniff

/user

add address=0.0.0.0/0 comment=”FTP backup” disabled=no group=ftp name=”ftp”

/user

set [find name=”ftp”] password=”mypass”

*Server configuration*

حالا که روتر به طور کامل پیکربندی شده ،ما باید ی سری تنظیمات مربوط به میزبان فایل های Backup را روی ویندوز(میزبان پشتیبان گیری) انجام دهیم. اول از همه، دانلود “MTBACKUP”از اینجا http://www.burex.net/mikrotik/mtbackup.zip

نحوه استفاده “mtbackup.exe” بصورت زیر است:

Usage: mtbackup.exe [input ftp script template] [output ftp script] [destination backup folder] [windows FTP client path]

Example: mtbackup.exe “c:\example\template.s” “c:\example\script.s” “c:\mikrotik-backups” “C:\Windows\System32\ftp.exe”

برنامه “mtbackup.exe” در یک پوشه موجود برای استفاده های بعدی کپی کنید.( در این مثال، مسیر “C:\mtbackup”انتخاب شده است)

*Creating an FTP script template*

برای این کار میتونیم از یک روش خیلی ساده استفاده کنیم. Notepad را باز میکنیم و دستورات زیر رو تایپ میکنیم:

o 192.168.0.1 21

USER ftp

mypass

binary

$

۱۹۲٫۱۶۸٫۰٫۱ – Router backup

close

quit

*توضیحی در مورد اسکریپت FTP

o 192.168.0.1 21: یک Connection  روی سرور FTPروتر خودتون ایجاد کنید -۱۹۲٫۱۶۸٫۰٫۱ در پورت ۲۱

USER ftp: یک نام کاربری برای login  کردن FTP انتخاب کنید.

Mypass: برای login کردن یک password انتخاب کنید.

Binary: از Binary بجای ASCLL برای نگهداری از فایل های پشتیبان استفاده کنید.

$: برای خاتمه این فرایند از علامت $  استفاده میکنیم.

۱۹۲٫۱۶۸٫۰٫۱ – Router backup: نام فایل backup  روتر

Close: اجازه ویرایش نده و یک ارتباط مناسب با FTP client ایجاد کن

Quit: باعث خروج از اجرای هر فرمان در FTP client ها

این فایلی که در Notpad ایجاد کردین را در یک مکان ذخیره کرد،توصیه میشه اسکریپت ها رو در فایل mtbackup.exe ذخیره کنید،در این مثال نام این فایل“ “mtscript.sمی باشد.اگر قصد دارید چندین روتر داشته باشید کافیه اسکربپت ها رو پشت سرهم با یک خط خالی بنویسید،بعنوان مثال:

o 192.168.0.1 21

USER ftp

mypass1

binary

$

۱۹۲٫۱۶۸٫۰٫۱ – Backup

close

o 192.168.0.2 21

USER ftp

mypass2

binary

$

۱۹۲٫۱۶۸٫۰٫۲ – Backup

close

o 192.168.0.3 21

USER ftp

mypass3

binary

$

۱۹۲٫۱۶۸٫۰٫۳ – Backup

close

quit

خب حالا که فایل اسکریپت اماده شد با استفاده از دستورات زیر یک تست سریع میگیریم:

C:\mtbackup\mtbackup.exe “c:\mtbackup\mtscript.s” “c:\mtbackup\script.s” “c:\mtbackup\backups”

اگر فایل ftp.exe  در Windows FTP client در مسیر C:\windows\system32  قرار نگرفته بود،مسیر با استفاده از دستوارت زیر ویرایش کنید:

C:\mtbackup\mtbackup.exe “c:\mtbackup\mtscript.s” “c:\mtbackup\script.s” “c:\mtbackup\backups” “d:\windows\system32\ftp.exe”

بعد از اینکه این دستورات اجرا شد،توجه کنید که پوشه backup شامل تمام backup های دسته بندی شده توسط تاریخ وارد شده است.

*Configuring Windows scheduler*

خب حالا باید سایر تنظیمات را روی سرورانجام بدیم (سروی که من استفاده میکنم سرور۲۰۰۸است )وتنظیمات مربوط به زمان بندی Backup  را انجام دهیم

از مسیر زیر وارد تنظیمات میشویم:

backup4

backup5

backup6

در تصویر بالا در قسمت Name یک نام مناسب برای این کار انتخاب کنید،شما میتونید Description  را بنویسید اما لزومی به انجام این کار نیست اما باید مطمئن باشید تیک مربوط به Run whether is logged on or not را زده باشید تا مطمئن باشید که اسکریپت ها اجرا میشه.همچنین تیک مربوط به  run with highest privileges را زده باشید با این گزینه شما مطمئن میشوید که اسکریپت ها به پوشه های ارسالی که توسط ویندوز محافظت میشه فرستاده میشود.

backup7

در این صفحه روی دکمه new کلیک کنید.

backup8

در این قسمت شما میتونید تنظیمات رو انجام بدین،بعنوان مثلا چون من میخواستم هرروز اسکریپت ها اجرا بشه گزینه daily رو انتخاب کردم همچنین میتونید تاریخ و ساعت اجرا رو هم تعیین کنید.همچنین شما میتونید بازدن تیک stop task if it rune longer than ی مدت زمانی را تعیین کنید و که اگه اجرای شما بیشتر از مدت مشخص شده طول کشید متوقف بشه چون احتمالا خطایی وجود دارد.سپس تنظیمات ok کنید.

backup9

خب در این پنجره روی New کلیک کرده و یک actions جدید ایجاد میکنیم.

backup10

در این قسمت Action  باید در حالت start a program باشد و از قسمت browse مسیر فایل mtbackup.exe را انتخاب میکنیم.در قسمت بعدی Add arguments اسکریپت زیر را وارد میکنیم:

“c:\mtbackup\mtscript.s” “c:\mtbackup\script.s” “c:\mtbackup\backups”

اگر هم فایل ftp.exe خارج از مسیر C:\windows\system32 hsj.ویرایش کنید اسکریپت بصورت زیر:

“c:\mtbackup\mtscript.s” “c:\mtbackup\script.s” “c:\mtbackup\backups” “d:\windows\system32\ftp.exe”

و در قسمت بعد Start in من مسیر پیشفرضی که انتخاب کردین رو وارد کنید بعد تنظیمات را  ذخیره کنید.

backup11

در این قسمت چک کنید تمام تنظیماتی که وارد کردید صحیح است ،اگر درست بود ok کنید در غیر اینصورت تنظیمات را دوباره انجام دهید و ویراش کنید.

*Final adjustments*

FTP – شما می توانید یک سرور FTP بر روی دستگاه خود که میزبان  پوشه Backup  است اجرا کنید.

backup12

– شما می توانید WEB انتخاب کنید، یک وب سرور مانند Apache برای فایل های Backup خودتون و بصورت online دریافت کنید و یا بر روی یک وب سرور محلی. با استفاده از mod_rewrite، شما می توانید آنها را با یک نام کاربری و رمز عبور protect کنید.

Nothing – شما میتونید به صورت مستقیم به فایل های خودتون دسترسی داشته باشید.

حالا شما تمام تنظیمات مربوط به Backup گیری اتوماتیک رو انجام دادین و اجرای آن از همین لحظه آغاز میشود .خب هر زمان که یک عاملی باعث خرابی سخت افزار یا هرگونه  config اشتباهی رخ بده شما میتونید با استفاده از این backup به اخرین تنظیمات خودتون خیلی ساده و سریع دسترسی پیدا کنید.

اگر چنانچه بخواهید بصورت دستی عملیات بکاپ گیری انجام بدهید باید از پنل سمت چپ گزینه file را انتخاب کنید.در پنجره file list  گزینه backup را بزنید.

backup13

در پنجره باز شده برای فایل بکاپ خود یک پسورد و یک نام انتخاب کنید و روی دکمه backup کلیک کنید حالا فایل شما ایجاد شده است.

backup14

backup15

امیدوارم مورد توجه واقع شده باشد.

همراه ما باشید Tantani.co

تنظیمات اولیه میکروتیک

تنظیمات اولیه میکروتیک

سلام به همه دوستان تن تنی . در پست قبلی شما رو با میکروتیک بطور مختصر آشنا کردم، در این پست سعی کردم شما رو با تنظیمات اولیه میکروتیک آشنا کنم،چرا که قبل از اجرای هر گونه سناریو شما باید با یکسری تنظیمات آشنا باشید. برای دسترسی به  این تنظیمات، یعنی تنظیمات روتر برد های میکروتیک راه های متفاوتی وجود دارد از جمله:

Telnet

SSH

Winbox(موضوع مورد بحث)

بیشتر بخوانید

میکروتیک چیست؟

میکروتیک چیست؟

سلام به همه دوستان تن تنی.در این پست سعی کردم شما رو با میکروتیک آشنا کنم و در پست های بعدی که براتون میزارم باهم تنظیمات مختلف روتر برد میکروتیک را انجام خواهیم داد. میکروتیک توسط دو دانشجوی MIT آمریکا دراروپای شرقی در لاتویا (لتونی) تاسیس شد.

Mikrotik1

سیستم عامل های میکروتیک از جمله اولین محصولات شرکت میکروتیک بود که با استفاده از هسته لینوکس ساخته شده بود.مهمترین هدف میکروتیک مسیریابی بود اما یکی دیگر از اهدافش ارائه محصولات با قیمت پایئن یعنی میشه گفت بعبارتی رقابت با محصولات گران قیمت سیسکو بود.شاید یکی از عواملی که باعث پیشرفت میکروتیک شد پایداری این محصولات بود،پایداری در ارائه سرویس در شبکه های مختلف از لحاظ گستردگی . بیشتر بخوانید